Can't find the 'libpq-fe.h header when trying to install pg gem centos 7

Q & ACategory: SystemCan't find the 'libpq-fe.h header when trying to install pg gem centos 7
Narin asked 1 year ago

[[email protected]]# bundle install

and I got error

Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

current directory: /root/.rbenv/versions/2.3.0/lib/ruby/gems/2.3.0/gems/pg-0.18.4/ext
/root/.rbenv/versions/2.3.0/bin/ruby -r ./siteconf20170711-70241-1w8d8nx.rb extconf.rb
checking for pg_config… no
No pg_config… trying anyway. If building fails, please try again with
–with-pg-config=/path/to/pg_config
checking for libpq-fe.h… no
Can’t find the ‘libpq-fe.h header
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers. Check the mkmf.log file for more details. You may
need configuration options.

Provided configuration options:
–with-opt-dir
–without-opt-dir
–with-opt-include
–without-opt-include=${opt-dir}/include
–with-opt-lib
–without-opt-lib=${opt-dir}/lib
–with-make-prog
–without-make-prog
–srcdir=.
–curdir
–ruby=/root/.rbenv/versions/2.3.0/bin/$(RUBY_BASE_NAME)
–with-pg
–without-pg
–enable-windows-cross
–disable-windows-cross
–with-pg-config
–without-pg-config
–with-pg_config
–without-pg_config
–with-pg-dir
–without-pg-dir
–with-pg-include
–without-pg-include=${pg-dir}/include
–with-pg-lib
–without-pg-lib=${pg-dir}/lib

To see why this extension failed to compile, please check the mkmf.log which can be found here:

/root/.rbenv/versions/2.3.0/lib/ruby/gems/2.3.0/extensions/x86_64-linux/2.3.0-static/pg-0.18.4/mkmf.log

extconf failed, exit code 1

Gem files will remain installed in /root/.rbenv/versions/2.3.0/lib/ruby/gems/2.3.0/gems/pg-0.18.4 for inspection.
Results logged to /root/.rbenv/versions/2.3.0/lib/ruby/gems/2.3.0/extensions/x86_64-linux/2.3.0-static/pg-0.18.4/gem_make.out

An error occurred while installing pg (0.18.4), and Bundler cannot continue.
Make sure that `gem install pg -v ‘0.18.4’` succeeds before bundling.

In Gemfile:
pg

1 Answers
Sovandara answered 1 year ago

Hi,

Please try install libpq-dev or its equivalent for your OS:

– For Ubuntu systems: sudo apt-get install libpq-dev
– On Red Hat Linux (RHEL) systems: yum install postgresql-devel
– For Mac Homebrew: brew install postgresql
– For Mac MacPorts PostgreSQL: gem install pg — –with-pg-config=/opt/local/lib/postgresql[version number]/bin/pg_config
– For OpenSuse: zypper in postgresql-devel

Your Answer

17 + 4 =